¿Qué es la Herramienta de cliente de red de SQL Server?

La herramienta de cliente de red de SQL Server es una herramienta gráfica que le permite realizar las tareas siguientes:

  • Crear conexiones de protocolo de red con los servidores especificados y cambiar el protocolo de red predeterminado.

  • Presentar información acerca de las bibliotecas de red instaladas actualmente en el sistema.

  • Presentar la versión de la biblioteca base de datos instalada actualmente en el sistema y establecer los valores predeterminados para sus opciones.

Para obtener más información acerca de la Herramienta de cliente de red de SQL Server, consulte “Administrar clientes" en los Libros en pantalla de SQL Server.


Ficha General

La sección siguiente muestra las opciones y funciones disponibles en la ficha General.

Opciones

Protocolos deshabilitados

Indica los protocolos disponibles no habilitados actualmente en este equipo. Para habilitar un protocolo, haga clic en el protocolo y, a continuación, haga clic en Habilitar.

Habilitar protocolos por orden

Indica los protocolos habilitados actualmente en este equipo. Los protocolos se enumeran en el orden en el que el sistema intentará utilizarlos para conexiones.

Habilitar

Habilita el protocolo resaltado en la lista Protocolos deshabilitados. Al hacer doble clic en el protocolo también se realizará esta función.

Deshabilitar

Deshabilita el protocolo resaltado actualmente en la lista Habilitar protocolos por orden. Al hacer doble clic en el protocolo también se realizará esta función.

Botones Subir y Bajar

Mueve el protocolo resaltado arriba y abajo en una lista. Esto permite cambiar el orden en que la biblioteca de red intentará utilizarlos para conexiones.

Propiedades

Muestra las propiedades de conexión predeterminadas del protocolo resaltado.

Forzar cifrado de protocolos

Permite el cifrado del protocolo mediante Secure Sockets Layer (SSL).

Habilita el protocolo de memoria compartida

Habilita el protocolo de memoria compartida para conexiones con el mismo equipo.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red

Cómo comprobar que SQL Server está a la escucha en AppleTalk


Configuración del valor predeterminado del protocolo de canalización con nombre

Esta sección muestra las opciones y las funciones disponibles en el cuadro de diálogo Configuración del valor predeterminado del protocolo de red para Canalizaciones con nombre.

Opciones

Canalización predeterminada

Especifica la canalización predeterminada que la biblioteca de red de Canalizaciones con nombre utilizará para intentar conectarse a la instancia de destino de Microsoft® SQL Server™.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo asignar un alias a una canalización alternativa

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Configuración del valor predeterminado del protocolo TCP/IP

Esta sección muestra las opciones y las funciones disponibles en el cuadro de diálogo Configuración del valor predeterminado del protocolo de red para TCP/IP.

Opciones

Puerto predeterminado

Especifica el puerto que la biblioteca de red de TCP/IP utilizará para intentar conectarse a la instancia de destino de Microsoft® SQL Server™. El valor predeterminado es 1433.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar TCP/IP

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Configuración del valor predeterminado del protocolo Multiprotocolo

Esta sección muestra las opciones y las funciones disponibles en el cuadro de diálogo Configuración del valor predeterminado del protocolo de red para Multiprotocolo.

Opciones

Protocolos RPC

Enumera los protocolos que la biblioteca de red de Multiprotocolo utilizará para intentar conectarse a la instancia de destino de Microsoft® SQL Server™. La biblioteca de red de Multiprotocolo probará cada protocolo en el orden especificado hasta que se establezca una conexión. A continuación se enumeran los nombres para los protocolos individuales. Cada uno de ellos debe separarse con un espacio.

Protocolo | Nombre
Multiprotocolo | nlrpc
Canalizaciones con nombre | nacn_np
TCP/IP | nacn_ip_tcp
IPX/SPX | nacn_spx

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red Multiprotocolo

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Configuración del valor predeterminado del protocolo NWLink IPX/SPX

Esta sección muestra las opciones y las funciones disponibles en el cuadro de diálogo Configuración del valor predeterminado del protocolo de red para NWLink IPX/SPX.

Opciones

Red predeterminada

Especifica el número de red NetWare. El valor predeterminado es 0.

Puerto predeterminado

Especifica el número de socket. El valor predeterminado es 33854.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red NWLink IPX/SPX

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Configuración del valor predeterminado del protocolo AppleTalk

Esta sección muestra las opciones y las funciones disponibles en el cuadro de diálogo Configuración del valor predeterminado del protocolo de red para AppleTalk.

Opciones

Zona predeterminada

Especifica la zona utilizada al registrar el servicio.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red AppleTalk

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Configuración del valor predeterminado del protocolo Banyan VINES

Esta sección muestra las opciones y las funciones disponibles en el cuadro de diálogo Configuración del valor predeterminado del protocolo de red para Banyan VINES.

Opciones

Grupo predeterminado

Especifica el grupo al que pertenece el servicio.

Organización predeterminada

Especifica la organización a la que pertenece el grupo.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red Banyan VINES

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Configuración del valor predeterminado del protocolo VIA

Esta sección muestra las opciones y las funciones disponibles en el cuadro de diálogo Configuración del valor predeterminado del protocolo de red para VIA.

Opciones

Fabricante

Especifica el fabricante del hardware que se utiliza con el protocolo VIA.

Puerto de servidor predeterminado

Especifica el puerto de servidor predeterminado. El valor predeterminado es 0:1433.

NIC de cliente predeterminado

Especifica la tarjeta de interfaz de red del cliente predeterminada. El valor predeterminado es 0.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Ficha Alias

La sección siguiente muestra las opciones y funciones disponibles en la ficha Alias.

Opciones

Configuraciones de alias del servidor

Muestra información acerca de los alias de servidor de los equipos a los que se conecta el cliente.

Alias del servidor

Indica el alias de servidor que se usa para el equipo al que se conecta el cliente.

Biblioteca de red

Indica la biblioteca de red de cliente utilizada en la entrada de configuración.

Parámetros de conexión

Indica los parámetros asociados con la dirección de conexión en la configuración de la biblioteca de red.

Agregar

Agrega una nueva configuración de biblioteca de red.

Quitar

Quita una configuración de biblioteca de red.

Modificar

Modifica una configuración de biblioteca de red.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red

Cómo comprobar que SQL Server está a la escucha en AppleTalk


Agregar (o Modificar) la configuración de biblioteca de canalizaciones con nombre

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para Canalizaciones con nombre

Opciones

Alias del servidor

Especificar un nombre único para la instancia de Microsoft® SQL Server™ que atiende a la biblioteca de red de Canalizaciones con nombre.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción Canalizaciones con nombre.

Nombre de servidor

Especifica el nombre del servidor de la instancia de destino de SQL Server.

Nombre de canalización

Especifica la canalización que la biblioteca de red de Canalizaciones con nombre utilizará para intentar conectarse a la instancia de destino de SQL Server.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo asignar un alias a una canalización alternativa

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) la configuración de biblioteca TCP/IP

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para TCP/IP.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red Sockets de TCP/IP.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción TCP/IP.

Nombre de servidor

Especifica la instancia de SQL Server que escucha a los clientes con Sockets de TCP/IP.

Determinar el puerto dinámicamente

Especifica que la biblioteca de red determinará el puerto dinámicamente. El puerto especificado en Número de puerto no se utilizará.

Número de puerto

Especifica el puerto que la biblioteca de red de TCP/IP utilizará para intentar conectarse a la instancia de destino de SQL Server. El valor predeterminado es 1433, el número de puerto que la biblioteca de red Windows Sockets utiliza generalmente con SQL Server. En la mayor parte de los casos, utilice el número de puerto predeterminado. Este campo sólo está activo si está desactivada la casilla de verificación Determinar el puerto dinámicamente.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar TCP/IP

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) la configuración de biblioteca de multiprotocolo

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para Multiprotocolo.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red Multiprotocolo.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción Multiprotocolo.

Nombre de servidor

Especifica la instancia de SQL Server que escucha a los clientes con Multiprotocolo.

Parámetros adicionales

Especifica parámetros de configuración adicionales para la biblioteca de red Multiprotocolo. Estos parámetros son opcionales.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red Multiprotocolo

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) la configuración de biblioteca NWLink IPX/SPX (Nombre de servicio)

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para NWLink IPX/SPX.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red NWLink IPX/SPX.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción NWLink IPX/SPX.

Especificar los parámetros por

Indica cómo se especifican los parámetros. Está activada la opción Nombre del servicio.

Nombre del servicio

Especifica el nombre del equipo con Microsoft Windows NT® 4.0 o Windows® 2000 donde se ejecuta una instancia de SQL Server. Esta información se almacena en el servicio bindery del servidor.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red NWLink IPX/SPX

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) la configuración de biblioteca NWLink IPX/SPX (Dirección de red)

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para NWLink IPX/SPX.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red NWLink IPX/SPX.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción NWLink IPX/SPX.

Especificar los parámetros por

Indica cómo se especifican los parámetros. Está activada la opción Dirección de red.

Dirección

Especifica la dirección MAC.

Puerto

Especifica el número de socket. El valor predeterminado es 33854.

Red

Especifica el número de red NetWare. El valor predeterminado es 0.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red NWLink IPX/SPX

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) la configuración de biblioteca de AppleTalk

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para AppleTalk.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red AppleTalk.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción AppleTalk.

Nombre del objeto

Especifica el objeto de servicio asignado por el administrador del sistema.

Zona

Especifica la zona utilizada al registrar el servicio.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red AppleTalk

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) la configuración de biblioteca de Banyan VINES

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para Banyan VINES.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red Banyan VINES.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción Banyan VINES.

Servicio

Especifica el nombre del servicio basado en PC StreetTalk que utiliza el servidor.

Grupo

Especifica el grupo al que pertenece el servicio.

Organización

Especifica la organización a la que pertenece el grupo.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar la biblioteca de red Banyan VINES

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) configuración de biblioteca de red para VIA

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para VIA.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red VIA.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. VIA está seleccionada.

Nombre de servidor

Especifica la instancia de SQL Server que escucha a los clientes con VIA.

Número de puerto del servidor

Especifica el número de puerto del servidor que se va a utilizar para la conexión con la instancia de SQL Server. El valor predeterminado es 0:1433.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Agregar (o Modificar) la configuración de otra biblioteca

Esta sección muestra las opciones y funciones disponibles en el cuadro de diálogo Agregar (o Modificar) configuración de biblioteca de red para otros protocolos.

Opciones

Alias del servidor

Especifica un nombre único para el servidor que ejecuta una instancia de Microsoft® SQL Server™ que está a la escucha mediante la nueva configuración de biblioteca de red.

Bibliotecas de red

Especifica la biblioteca de red que se utilizará para conectar con el servidor. Está activada la opción Otra.

Nombre de archivo

Especifica el nombre y ubicación de la DLL de la biblioteca de red suministrada por otro fabricante.

Parámetros

Especifica los parámetros necesarios y su formato.

Vea también

Cómo agregar una configuración de biblioteca de red

Cómo configurar un cliente para utilizar una biblioteca de red no estándar

Cómo eliminar una configuración de biblioteca de red

Cómo modificar una configuración de biblioteca de red


Ficha Opciones de biblioteca de base de datos

Esta sección muestra las opciones y funciones disponibles en la ficha Opciones de biblioteca de base de datos.

Opciones

Nombre de archivo

Indica el nombre de archivo y la ubicación de la biblioteca de base de datos instalada en este equipo.

Versión

Indica el número de versión de la biblioteca de base de datos instalada en este equipo.

Fecha

Indica la fecha en que se instaló la biblioteca de base de datos en este equipo.

Tamaño

Indica el tamaño de archivo de la biblioteca de base de datos instalada en este equipo.

Conversión automática de ANSI a OEM

Habilita la biblioteca de base de datos para convertir un juego de caracteres de OEM a ANSI al comunicar con Microsoft® SQL Server™ desde el cliente y de ANSI a OEM al comunicar con el cliente desde SQL Server. Esta opción está activada de forma predeterminada.

Usar configuración internacional

Habilita la biblioteca de base de datos para obtener los formatos de fecha, hora y moneda del sistema en lugar de utilizar parámetros no modificables. Esta opción está activada de forma predeterminada en los clientes que ejecuten sistemas operativos Microsoft Windows® de 32 bits.

Vea también

Cómo establecer las preferencias de conversión de la biblioteca de base de datos


Ficha Bibliotecas de red

Esta sección muestra las opciones y funciones disponibles en la ficha Bibliotecas de red.

Opciones

Biblioteca de red

Enumera las bibliotecas de red de cliente de Microsoft® SQL Server™ instaladas en este equipo.

Nombre de archivo de biblioteca

Muestra la ubicación de las bibliotecas de red del cliente de SQL Server instaladas en este equipo.

Versión

Muestra los números de versión de las bibliotecas de red del cliente de SQL Server instaladas en este equipo.

Fecha del archivo

Muestra las fechas en que se instalaron en este equipo las bibliotecas de red del cliente de SQL Server.

Tamaño

Muestra los tamaños de archivo de las bibliotecas de red del cliente de SQL Server instaladas en este equipo.

Vea también

Cómo mostrar los números de la versión de biblioteca


Administrar clientes

Un cliente es una aplicación de usuario que utiliza los servicios proporcionados por un servidor. El equipo en el que se ejecuta esta aplicación se llama equipo cliente. El software de cliente permite a los equipos conectarse a una instancia de Microsoft® SQL Server™ en una red.

Los clientes de SQL Server pueden incluir aplicaciones de varios tipos, como:

  • Consumidores OLE DB.

    Estas aplicaciones utilizan el proveedor OLE DB de Microsoft para SQL Server o el proveedor OLE DB de Microsoft para ODBC para conectarse y conversar con instancias de SQL Server. Los proveedores OLE DB actúan como intermediarios entre una instancia de SQL Server y las aplicaciones cliente que consumen datos de SQL Server como conjuntos de filas OLE DB.

  • Aplicaciones ODBC.

    Incluyen herramientas de cliente instaladas con SQL Server, como el Administrador corporativo de SQL Server y el Analizador de consultas de SQL Server, además de otras aplicaciones que utilizan el controlador ODBC de SQL Server ODBC para conectarse y conversar con una instancia de SQL Server.

  • Clientes de bibliotecas de bases de datos, que incluyen la herramienta de símbolo del sistema de SQL Server isql y clientes escritos a bibliotecas de bases de datos.

Independientemente del tipo de aplicación, administrar un cliente consiste principalmente en configurar su conexión con los componentes de servidor de SQL Server. Según sean los requisitos del sitio, la administración de clientes puede ser tan simple como escribir el nombre del equipo servidor o tan compleja como crear una biblioteca de entradas de configuración personalizada para acomodarse a un entorno multiservidor diverso.


Cómo iniciar la Herramienta de cliente de red (Windows)

Para iniciar la Herramienta de cliente de red

  • En el menú Inicio, seleccione Programas/Microsoft SQL Server y, a continuación, haga clic en Herramienta de cliente de red.


Cómo mostrar la biblioteca de red de números de versión (Herramienta de cliente de red)

Para mostrar los números de versión de la biblioteca

  • Haga clic en la ficha Bibliotecas de red.

    Se muestran la biblioteca de red, el nombre, la versión, la fecha y el tamaño del archivo de la biblioteca.


Cómo establecer las preferencias de conversión de la biblioteca de base de datos (Herramienta de cliente de red)

Nota Este procedimiento se aplica a clientes con el sistema operativo de 32 bits Microsoft® Windows®.

Establecer las preferencias de conversión de la biblioteca de base de datos

  1. Haga clic en la ficha Opciones de biblioteca de base de datos.

  2. Active o desactive la casilla de verificación Conversión automática de ANSI a OEM.

  3. Active o desactive la casilla de verificación Usar configuración internacional.


Cómo agregar una configuración de biblioteca de red (Herramienta de cliente de red)

Para agregar una configuración de biblioteca de red

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, en Bibliotecas de red, seleccione una de las bibliotecas de red.

  3. Escriba el alias del servidor y cualquier parámetro requerido por la biblioteca de red seleccionada.


Cómo modificar una configuración de biblioteca de red (Herramienta de cliente de red)

Para modificar una configuración de biblioteca de red

  1. Haga clic en la ficha Alias y, a continuación, haga clic en la configuración del protocolo de red que vaya a modificar.

  2. Haga clic en Modificar.

  3. En el cuadro de diálogo Modificar configuración de biblioteca de red, modifique la información que va a cambiar.


Cómo eliminar una configuración de biblioteca de red (Herramienta de cliente de red)

Para eliminar una configuración de biblioteca de red

  1. Haga clic en la ficha Alias y, a continuación, haga clic en la configuración de la biblioteca de red que vaya a eliminar.

  2. Haga clic en Eliminar.


Cómo asignar alias a clientes para canalizaciones alternativas (Herramienta de cliente de red)

Para asignar alias a clientes para canalizaciones alternativas

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en Canalizaciones con nombre.

  3. En el cuadro Alias del servidor, escriba el alias del servidor.

  4. En Parámetros de conexión, en el cuadro Nombre de canalización, escriba el nombre de canalización alternativo (por ejemplo, \\myserver\pipe\altpipe).


Cómo configurar un cliente para que utilice la biblioteca de red multiprotocolo (Herramienta de cliente de red)

Nota Antes de crear una configuración multiprotocolo en un cliente, asegúrese de que el equipo tenga cargado al menos un protocolo IPC bajo Multiprotocolo en el servidor (Canalizaciones con nombre, NWLink IPX/SPX, TCP/IP o Windows Sockets).

Para configurar un cliente para que use la biblioteca de red multiprotocolo

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en Multiprotocolo.

  3. En el cuadro Alias del servidor, escriba el nombre de la instancia de Microsoft® SQL Server™ que esté a la escucha en la biblioteca de red multiprotocolo.

  4. Deje vacío el cuadro Parámetros adicionales, a menos que el servidor requiera parámetros específicos. Compruebe los parámetros con el administrador de la red antes de escribirlos.


Cómo configurar un cliente para utilizar TCP/IP (Herramienta de cliente de red)

Para configurar el uso de TCP/IP en clientes

  1. Haga clic en la ficha General y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en TCP/IP.

  3. En el cuadro Alias del servidor, escriba el alias de la instancia de Microsoft® SQL Server™ que esté a la escucha en la biblioteca de red Windows Sockets.

    En TCP/IP, también puede especificar el servidor con la dirección IP en lugar de con el nombre.

  4. Haga algo de lo siguiente:
    • Active la casilla de verificación Determinar el puerto dinámicamente para determinar el puerto automáticamente.

    • Desactive la casilla de verificación Determinar el puerto dinámicamente para establecer el puerto manualmente y, a continuación, en el cuadro Número de puerto, escriba el número de puerto.

Para obtener más información acerca de otros protocolos TCP/IP que acepten Windows Sockets, consulte la documentación de TCP/IP.


Para configurar un cliente para que utilice la biblioteca de red NWLink IPX/SPX (Herramienta de cliente de red)

Para configurar el uso de la biblioteca de red NWLink IPX/SPX en clientes

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en NWLink IPX/SPX.

  3. En el cuadro Alias del servidor, escriba el alias de la instancia de Microsoft® SQL Server™ que esté a la escucha en la biblioteca de red NWLink IPX/SPX.

  4. En Parámetros de conexión, haga clic en Nombre del servicio o Dirección de red, y a continuación haga algo de lo siguiente:
    • Si hizo clic en Nombre de servicio, escriba el nombre del servicio.

      Nombre de servicio es el nombre del equipo con Microsoft Windows NT® 4.0 o Windows® 2000 donde se ejecuta una instancia de SQL Server. Este nombre se almacena en el servicio Bindery del equipo servidor.

    • Si hizo clic en Dirección de red, escriba la dirección (la dirección MAC), el puerto (número del socket) y la red (número de red de NetWare).


Cómo configurar un cliente para que utilice la biblioteca de red AppleTalk (Herramienta de cliente de red)

Para configurar el uso de la biblioteca de red AppleTalk en clientes

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en AppleTalk.

  3. En el cuadro Alias del servidor, escriba el nombre de la instancia de Microsoft® SQL Server™ que esté a la escucha en la biblioteca de red AppleTalk.

  4. En Parámetros de conexión, escriba el nombre del objeto de AppleTalk y los identificadores de zona opcionales.


Cómo configurar el uso de la biblioteca de red Banyan VINES en clientes (Herramienta de cliente de red)

Para configurar el uso de la biblioteca de red Banyan VINES en clientes

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en Banyan VINES.

  3. En el cuadro Alias del servidor, escriba el alias de la instancia de Microsoft® SQL Server™ que esté a la escucha en la biblioteca de red Banyan VINES.

  4. En Parámetros de conexión, escriba el servicio y la organización de VINES. Puede utilizar el valor predeterminado de MSSQL para grupo.


Cómo configurar un cliente para que utilice la biblioteca de red VIA (Herramienta de cliente de red)

Para configurar el uso de la biblioteca de red Banyan VINES en clientes

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en VIA.

  3. En el cuadro Alias del servidor, escriba el alias de la instancia de Microsoft® SQL Server™ que esté a la escucha en la Biblioteca de red VIA.

  4. En Parámetros de conexión, escriba el nombre del servidor y el número de puerto del servidor.


Cómo configurar el uso de una biblioteca de red no estándar en clientes (Herramienta de cliente de red)

Para configurar el uso de una biblioteca de red no estándar en clientes

  1. Haga clic en la ficha Alias y, a continuación, haga clic en Agregar.

  2. En el cuadro de diálogo Agregar configuración de biblioteca de red, haga clic en Otros.

  3. En el cuadro Alias del servidor, escriba el alias de la instancia de Microsoft® SQL Server™ que está a la escucha en la biblioteca de red que piensa instalar.

  4. En Parámetros de conexión, escriba el nombre de archivo (el archivo tiene que ser una DLL) de la biblioteca de red instalada. No escriba la extensión DLL.

  5. Si es necesario, escriba información adicional en el cuadro Parámetros (como el nombre de usuario y la contraseña). Utilice la coma como separador entre los parámetros.


Cómo comprobar que SQL Server está a la escucha en AppleTalk y puede aceptar una conexión de cliente (Herramienta de cliente de red)

Para comprobar que SQL Server está a la escucha en AppleTalk y puede aceptar una conexión de cliente

  1. Copie la biblioteca de red de cliente de AppleTalk (Dbmsadsn.dll) desde el directorio \WINNT\system32 del servidor al mismo directorio de un equipo remoto que ejecute Servicios de Microsoft® Windows NT® o Microsoft Windows® 2000 para Macintosh.

  2. En la estación de trabajo remota, inicie Configuración del cliente de SQL Server.

  3. Si AppleTalk se encuentra en la lista Protocolos deshabilitados, haga clic en AppleTalk y, a continuación, haga clic en Habilitar.

  4. En la lista Protocolos habilitados por orden, haga clic en AppleTalk y, a continuación, haga clic en el botón Arriba hasta que AppleTalk se encuentra en la parte superior de la lista.

  5. Haga clic en Aceptar.

  6. Intente una conexión ISQL con el nombre de objeto del servicio AppleTalk.

    Por ejemplo, en la línea de comandos, escriba:

    isql -Usa -P -Sservicename

    Si puede conectar con ISQL y ejecutar consultas, el servidor está correctamente configurado y acepta conexiones.

    Nota La biblioteca de red Microsoft Win32® AppleTalk (ADSP) para clientes (Dbmsadsn.dll) ha sido incluida para comprobar conexiones ADSP y solucionar problemas en las conexiones AppleTalk entre clientes Macintosh y Microsoft SQL Server™. Esta biblioteca de red está diseñada de forma que sólo se utilice para probar conexiones entre clientes remotos y una instancia de SQL Server. Si intenta establecer conexiones locales a través de la biblioteca de red ADSP con una instancia de un servidor SQL Server que esté a la escucha en AppleTalk, se recibirá el siguiente error de red: Error de biblioteca de red 11: getsockopt().


Cómo comprobar la versión del controlador de ODBC SQL Server (Windows)

Nota Siga estos pasos sólo si ejecuta el sistema operativo Microsoft® Windows NT® 4.0.

Para comprobar la versión del controlador de ODBC SQL Server (ODBC de 32 bits)

  1. En el Panel de control, haga doble clic en el icono Orígenes de datos ODBC.

  2. Haga clic en la ficha Controladores.

    La información para la entrada Microsoft SQL Server™ se muestra en la columna Versión.


Copyright y renuncia de Microsoft SQL Server 2000

Este documento, incluidas las aplicaciones de ejemplo que contiene, se proporciona con propósito informativo únicamente y Microsoft no otorga garantías expresas ni implícitas en este documento. La información contenida en este documento, incluidos los ejemplos, las direcciones URL y otras referencias a sitios Web de Internet, está sujeta a modificaciones sin previo aviso. El usuario asume todos los riesgos resultantes del uso de este documento.

El objetivo principal de los ejemplos es ilustrar un concepto o un uso razonable de una instrucción o cláusula determinada. La mayoría de los ejemplos no incluyen todo el código que debería tener un sistema totalmente productivo, puesto que gran parte de la validación de datos comunes y administración de errores se elimina para resaltar un determinado concepto o instrucción. No existe soporte técnico disponible para estos ejemplos o el código fuente proporcionado.

A menos que se indique lo contrario, los nombres de las compañías, organizaciones, productos, personas y eventos mencionados son ficticios. No se pretende indicar, ni debe deducirse ninguna asociación con compañías, organizaciones, productos, personas o eventos reales. Es responsabilidad del usuario el cumplimiento de todas las leyes de derechos de autor aplicables. Sin limitar los derechos del copyright, ninguna parte de este documento puede ser reproducida, almacenada o introducida en ningún sistema de recuperación, transmitida de ninguna forma ni por ningún medio (ya sea electrónico, mecánico, mediante fotocopias o grabaciones) con ningún propósito sin la previa autorización por escrito de Microsoft Corporation.

Microsoft puede ser titular de patentes, solicitudes de patentes, marcas, derechos de autor y otros derechos de propiedad intelectual sobre los contenidos de este documento. El suministro de este documento no le otorga ninguna licencia sobre estas patentes, marcas, derechos de autor u otros derechos de propiedad intelectual, a menos que ello se prevea en un contrato por escrito de licencia de Microsoft.

©1996-2000 Microsoft Corporation. Reservados todos los derechos.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Win32, Windows 2000, Windows y Windows NT son marcas registradas o marcas de Microsoft Corporation en los Estados Unidos y/o otros países.

Otros nombres de productos y compañías mencionados aquí pueden ser marcas comerciales de sus respectivos propietarios.

Versión: 8.00.000


 Ayuda de Herramienta de cliente de red

Consulte los libros en pantalla de SQL Server para revisar este tema.